自动化部署必备技能—定制化RPM包

回顾下安装软件的三种方式:

1、编译安装软件,优点是可以定制化安装目录、按需开启功能等,缺点是需要查找并实验出适合的编译参数,诸如MySQL之类的软件编译耗时过长。
2、yum安装软件,优点是全自动化安装,不需要为依赖问题发愁了,缺点是自主性太差,软件的功能、存放位置都已经固定好了,不易变更。
===>如果你现在还为是使用编译安装软件还是使用yum安装软件发愁,那你就out了。
3、编译源码,根据自己的需求做成定制RPM包–>搭建内网yum仓库–yum安装。结合前两者的优点,暂未发现什么缺点。可能的缺点就是RPM包的通用性差,只能适用于本公司的环境。另外一般人不会定制RPM包。这是中大型互联网企业运维自动化的必要技能。

这里也不介绍rpm的概念,想了解的朋友可以查看http://www.ibm.com/developerworks/cn/linux/l-rpm/

这里也不介绍rpmbuild这个打包工具了,想了解的朋友自行谷歌百度。但我不建议大家花太多的时间去学习这个命令,比较晦涩,而且我会在下面介绍更简单的命令。

FPM打包工具

FPM的作者是jordansissel
FPM的github:https://github.com/jordansissel/fpm
FPM功能简单说就是将一种类型的包转换成另一种类型。

1. 支持的源类型包

  1. dir 将目录打包成所需要的类型,可以用于源码编译安装的软件包
  2. rpm 对rpm进行转换
  3. gem 对rubygem包进行转换
  4. python 将python模块打包成相应的类型

2. 支持的目标类型包

  1. rpm 转换为rpm包
  2. deb 转换为deb包
  3. solaris 转换为solaris包
  4. puppet 转换为puppet模块

3. FPM安装

  1. fpm是ruby写的,因此系统环境需要ruby,且ruby版本号大于1.8.5。
  2. # 安装ruby模块
  3. yum -y install ruby rubygems ruby-devel
  4. # 查看当前使用的rubygems仓库
  5. gem sources list
  6. # 添加淘宝的Rubygems仓库,外国的源慢,移除原生的Ruby仓库
  7. gem sources --add https://ruby.taobao.org/ --remove http://rubygems.org/
  8. # 安装fpm,gem从rubygem仓库安装软件类似yum从yum仓库安装软件。首先安装低版本的json,高版本的json需要ruby2.0以上,然后安装低版本的fpm,够用。
  9. gem install json -v 1.8.3
  10. gem install fpm -v 1.3.3
  11. # 上面的2步安装仅适合CentOS6系统,CentOS7系统一步搞定,即gem install fpm

4. FPM参数

详细使用见fpm –help

常用参数

  1. -s 指定源类型
  2. -t 指定目标类型,即想要制作为什么包
  3. -n 指定包的名字
  4. -v 指定包的版本号
  5. -C 指定打包的相对路径 Change directory to here before searching forfiles
  6. -d 指定依赖于哪些包
  7. -f 第二次打包时目录下如果有同名安装包存在,则覆盖它
  8. -p 输出的安装包的目录,不想放在当前目录下就需要指定
  9. --post-install 软件包安装完成之后所要运行的脚本;同--after-install
  10. --pre-install 软件包安装完成之前所要运行的脚本;同--before-install
  11. --post-uninstall 软件包卸载完成之后所要运行的脚本;同--after-remove
  12. --pre-uninstall 软件包卸载完成之前所要运行的脚本;同--before-remove

使用实例–实战定制nginx的RPM包

1. 安装nginx

  1. yum -y install pcre-devel openssl-devel
  2. useradd nginx -M -s /sbin/nologin
  3. tar xf nginx-1.6.2.tar.gz
  4. cd nginx-1.6.2
  5. ./configure --prefix=/application/nginx-1.6.2 --user=nginx --group=nginx --with-http_ssl_module --with-http_stub_status_module
  6. make && make install
  7. ln -s /application/nginx-1.6.2/ /application/nginx

2. 编写脚本

  1. [root@oldboy ~]# cd /server/scripts/
  2. [root@oldboy scripts]# vim nginx_rpm.sh # 这是安装完rpm包要执行的脚本
  3. #!/bin/bash
  4. useradd nginx -M -s /sbin/nologin
  5. ln -s /application/nginx-1.6.2/ /application/nginx

3. 打包

  1. [root@oldboy ~]# fpm -s dir -t rpm -n nginx -v 1.6.2 -d 'pcre-devel,openssl-devel' --post-install /server/scripts/nginx_rpm.sh -f /application/nginx-1.6.2/
  2. no value for epoch is set, defaulting to nil {:level=>:warn}
  3. no value for epoch is set, defaulting to nil {:level=>:warn}
  4. Created package {:path=>"nginx-1.6.2-1.x86_64.rpm"}
  5. [root@oldboy ~]# ll -h nginx-1.6.2-1.x86_64.rpm
  6. -rw-r--r-- 1 root root 6.7M Nov 1 10:02 nginx-1.6.2-1.x86_64.rpm

4. 安装rpm包

安装rpm包的三种方法:

  • rpm命令安装
  1. [root@LB-nginx-01 ~]# rpm -ivh nginx-1.6.2-1.x86_64.rpm
  2. error: Failed dependencies:
  3. pcre-devel is needed by nginx-1.6.2-1.x86_64
  4. openssl-devel is needed by nginx-1.6.2-1.x86_64
  5. 但会报如上依赖错误,需要先yum安装依赖才能安装rpm包。
  • yum命令安装rpm包
  1. yum -y localinstall nginx-1.6.2-1.x86_64.rpm
  2. 这个命令会自动先安装rpm包的依赖,然后再安装rpm包。

注意事项

1. 相对路径问题

  1. # 相对路径
  2. [root@oldboy nginx]# fpm -s dir -t rpm -n nginx -v 1.6.2 .
  3. no value for epoch is set, defaulting to nil {:level=>:warn}
  4. no value for epoch is set, defaulting to nil {:level=>:warn}
  5. Created package {:path=>"nginx-1.6.2-1.x86_64.rpm"}
  6. [root@oldboy nginx]# rpm -qpl nginx-1.6.2-1.x86_64.rpm
  7. /client_body_temp
  8. /conf/extra/dynamic_pools
  9. /conf/extra/static_pools
  10. …………
  11. # 绝对路径
  12. [root@oldboy ~]# fpm -s dir -t rpm -n nginx -v 1.6.2 /application/nginx-1.6.2/
  13. no value for epoch is set, defaulting to nil {:level=>:warn}
  14. no value for epoch is set, defaulting to nil {:level=>:warn}
  15. Created package {:path=>"nginx-1.6.2-1.x86_64.rpm"}
  16. [root@oldboy ~]# rpm -qpl nginx-1.6.2-1.x86_64.rpm
  17. /application/nginx-1.6.2/client_body_temp
  18. /application/nginx-1.6.2/conf/extra/dynamic_pools
  19. /application/nginx-1.6.2/conf/extra/static_pools
  20. /application/nginx-1.6.2/conf/fastcgi.conf
  21. /application/nginx-1.6.2/conf/fastcgi.conf.default
  22. …………
  23. 使用rpm -qpl 命令可以查看rpm包的内容。
  24. 注:fpm类似tar打包一样,只是fpm打的包能够被yum命令识别而已。

2. 软链接问题

  1. [root@oldboy ~]# fpm -s dir -t rpm -n nginx -v 1.6.2 /application/nginx
  2. no value for epoch is set, defaulting to nil {:level=>:warn}
  3. File already exists, refusing to continue: nginx-1.6.2-1.x86_64.rpm {:level=>:fatal}
  4. # 报错是因为当前目录存在同名的rpm包,可以使用-f参数强制覆盖。
  5. [root@oldboy ~]# fpm -s dir -t rpm -n nginx -v 1.6.2 -f /application/nginx
  6. no value for epoch is set, defaulting to nil {:level=>:warn}
  7. Force flag given. Overwriting package at nginx-1.6.2-1.x86_64.rpm {:level=>:warn}
  8. no value for epoch is set, defaulting to nil {:level=>:warn}
  9. Created package {:path=>"nginx-1.6.2-1.x86_64.rpm"}
  10. 打包看似成功,但查看包的内容,只是这一个软链接文件。
  11. [root@oldboy ~]# rpm -qpl nginx-1.6.2-1.x86_64.rpm
  12. /application/nginx
  13. 原因:目录结尾的/问题,类似rm删除软链接目录

定制LNMP的RPM包思路

编译安装好nginx,mysql,php,此处有个问题,就是php的大部分依赖环境是通过yum安装的,但有一个libiconv-1.14.tar.gz包需要编译安装,安装时已经指定了安装目录,只需一同打包即可。

还有一个问题,就是mysql这个目录比较大,用fpm打包耗时长。平时我们有可能需要对nginx或php做优化,这样又得重新打包。因此我们可以将mysql分离出来,分别打包。只需在制作nginx+php的rpm包时添加mysql的依赖即可。

  1. # 参考命令
  2. [root@web2 ~]# fpm -s dir -t rpm -n web2 -v 1.1 \
  3. --description 'lnmp.cms,bbs.blog' \
  4. -d ‘libxslt-devel,nfs-utils,rpcbind,mysql,libmcrypt-devel,mhash,mhash-devel,mcrypt' \
  5. --post-install /server/scripts/lnmp-init.sh \
  6. /application /usr/local/libiconv/ /app/logs/ /data0/ /server/

本文转载于张耀的博客,原文链接

13
如无特殊说明,文章均为本站原创,转载请注明出处

该文章由 发布

这货来去如风,什么鬼都没留下!!!
发表我的评论

Hi,请填写昵称和邮箱!

取消评论
代码 贴图 加粗 链接 删除线 签到